Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Solved: FreeFlightPro app does not find my connected bebop 1


New member
Sep 16, 2022
Reaction score

I am new with the bebop 1.
Just bought two here in germany for 50 € each in new condition from a warehouse clearing of a professional german seller on ebay that gives me a 1-year-guarantee. The Seller says that the drones are new, only were used as display in a shop or so. When the drones arrived protection adhessives e.g. on the bottom stille sticked on the drones, so it seems that they are really in new condition. So I think he did not sell me broken drones.
The seller told that the drones do not come with batteries. I think this is because the original parrot-batteries that came with the drones were dead, so he he did remove it. So I ordered three aftermarked batteries from german seller vhbw that got good reviews.

I started the first drone and connected it to my android-smartphone, what did well. Of course it tells me in the wifi-menu of the smartphone that the smartphone ist connected to the bebop, but the internet may not be available (because the bebop is not an internet-router). Afterwards I started the FreflightPro app I have had already installed. But FreeFlightPro always tells me that the sync failed and that I should check my internet-connection.
I tryed the same with the second drone. Did not work either, same problem.
Then I tried it with another smartphone: It happens the same on the other smartphone: Wifi-connection to the drones can be easily established, but FreflightPro refuses to sync with the drones.
Last I tried to connect the drones to the Skycontroller I also purchased. Skycontroller shows on the left side besides the wifi-symbol a red LED, On the right side beside the battery-symbol 1 white LED an below that on the right side, besides the drone-symbol one red LED. But here also the two bebops refuse both to react on commands sent from the skycontroller.
I do not think the wifi-modules in the drones are broken, because connections to the smartphones are established.

Can anybody help?

Wanted to give my daughter a nice drone with good camera as a christmas gift. The other one I wanted to use as a support for my work as a forester to get a quick overview on forest stands from above. No I already fail to get a connection to the App or the Skycontroller. I know the bepop 1 is outdated, but I saw on youtube people still flying this drone in 2021 and 2022 with pleasure.

All the videos I saw on the internet about connecting bebop and app it seems to be so easy....

Thanks in advance for your help!

Last edited:

I could solve the problem myself:
After my post here I read in a german forum, that lots of bepop pilots run in trouble using FreeflightPro. One of the guys gave the advice to avoid FreeflightPro because it is known for its trouble and use instead the older FreeFlight 3, version 3.9.24.

I did so and it works fine! Both bebops I have here work on that older app.

You can get FreeFlight 3, version 3.9.24 here: https://m.apkpure.com/de/freeflight-pro/com.parrot.freeflight3/download/390024-APK

Nice flights

  • Like
Reactions: RainyShadow

New Posts

Members online

No members online now.

Forum statistics

Latest member