Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Anafi problem : battery doesn't fit anymore

LadyLiyah

Member
Joined
Dec 23, 2018
Messages
5
Reaction score
1
Hi all,

first of all I'm french so please excuse my poor english...

So yesterday I took my Anafi out for a quick shot at night. I didn't had much time so i skipped the update (drone and controller). I tried to flight the drone but something was wrong - it took off but didn't start recording. So I landed it (that was an unexpected rough landing eventhough it was close from the ground - like something as clearly wrong...), launched the update but was short on battery. I had a fully loaded extra battery so I pulled off the one on the drone and that's when problems started... I tried to put the other battery but was not able to "fully" click it. I tried to put back the first one to see if the extra battery was the issue but same problem... I tried to move - of course with extreme care - every part of the drone but nothing seems to be out of its "regular place".
When I try to put the battery back, the drone also immediatly turns on like it's ready to fly (blue light / camera stabilisation) but I'm not able to turn it off like I used to (double tap on battery button).
By the way, the drone crashed once two months ago but worked perfectly fine since then.

I'm feeling a bit desperate here... Can't see the same issue anywhere... Please help (and make the perfect christmas gift) !
Thanks in advance,
 

Attachments

  • 20181223_091109.jpg
    20181223_091109.jpg
    2.4 MB · Views: 50
  • 20181223_091114.jpg
    20181223_091114.jpg
    1.1 MB · Views: 52
  • 20181223_091131.jpg
    20181223_091131.jpg
    1.2 MB · Views: 49
  • 20181223_091136.jpg
    20181223_091136.jpg
    1.1 MB · Views: 37

MustangPhil

Well-known member
Joined
Jul 27, 2018
Messages
522
Reaction score
380
Location
France
Bonjour,
Je rebondis sur ton ‘double tap on battery button to turn it off’ pour préciser que pour l’allumer il faut appuyer une fois (très court) et pour l’éteindre aussi.
Si on maintient le bouton, on active d’autres fonctions (mesure du reste de la charge batteri, ou plus long...le reboot du drone).
Pour changer de batterie, il faut d’abord éteindre le drone correctement puis placer l’autre et rallumer l’Anafi en pressant 1 fois très peu de temps le bouton on.
Pour la mise à jour, pourrais tu désinstaller l’application, rebooter l’anafi et l’éteindre, puis la réinstaller, brancher la télécommande, faire la mise à jour de la télécommande puis en dernier, allumer l’Anafi et faire la mise à jour de celui ci à la toute fin.
Attention si tu as deux batteries, elles sont ‘intelligentes’ et doivent aussi mises à jour l’une après l’autre.
Tu peux nous dire le type de téléphone que tu utilises ? (Android ou iOS...)

Hello, to switch off the Anafi, one single short tap on the battery button is required as well as to switch it off, otherwise you may activate other functions such as battery check... or droit reboot).
The sequence to change battery is the following : switch off the Anafi (one short press on top button) and when it is ‘off’, remove the battery, replace by the new one, when in place, one short press on the top button should start the Anafi.
For software updates, first de install Free Flight 6 app, install the new one. Reboot the Anafi and switch it off, then reinstall the new app, connect the radiocommand, update the radio command, then switch on the Anafi and update the Anafi.
Be also careful if you have two batteries, to update both of them.
Can you tell us what kind of phone you have (Android / iOS ?)
 

MustangPhil

Well-known member
Joined
Jul 27, 2018
Messages
522
Reaction score
380
Location
France
On voit aussi sur tes photos que la batterie n’est as enclenchée correctement.
En forçant un peu, n’aurait tu pas déplacé les picots des connexions ?
Il faudrait enlever la batterie et remettre les picots de l’Anafi ‘dans le bon axe’ et s’assurer que ta batterie est bien enclenchée correctement.
Je vais faire des photos du miens pour te montrer...

Looking at the photos, it seems battery is not correctly fitted.
A wrong or forced connection may have displaced some of the connectors.
I’ll post pictures of mine to show you what I mean...
 

Dirk_ANAFI

Well-known member
Joined
Aug 7, 2018
Messages
1,177
Reaction score
471
Location
NRW, Germany
I can see the problem:
The upper left pin of Anafi's 8-pin header is bent to the right side and there touches the upper right pin.
You can carefully try to bend the pin with a small screwdriver to it's upright position.
If it breaks, contact the seller.
 

LadyLiyah

Member
Joined
Dec 23, 2018
Messages
5
Reaction score
1
Salut ! Et merci pour tes réponses.
Alors, point par point (et en français, ça va tellement être plus facile)
Pour le double tap, je t'avoue qu'avec l'émotion j'ai un doute maintenant sur le turn off mais une chose est sûre, avec une seule pression il ne s'éteint pas non plus depuis la panne.
Ensuite, la batterie est effectivement mal enclenchée car c'est tout mon problème ! Depuis hier, je n'arrive plus du tout à "enfoncer" complètement la ou les batteries. J'ai retiré de façon normale ma batterie mais impossible de la remettre. Ni ma seconde. Je n'ai pas du tout forcé, ni pour la retirer ni pour insérer les autres.
 

LadyLiyah

Member
Joined
Dec 23, 2018
Messages
5
Reaction score
1
Thanks to your answers now i can see the issue ! I don't get it because i always take it off very precautiously but I guess it wasn't enough. I'm trying yo fix that and I'll let you know ! Thanks guys.
 

MustangPhil

Well-known member
Joined
Jul 27, 2018
Messages
522
Reaction score
380
Location
France
Ça devrait ressembler à ça ....
 

Attachments

  • DAD7AC8B-B461-4AEE-949C-8A643D87D2C9.jpeg
    DAD7AC8B-B461-4AEE-949C-8A643D87D2C9.jpeg
    531.5 KB · Views: 24

LadyLiyah

Member
Joined
Dec 23, 2018
Messages
5
Reaction score
1
OKAY GUYS !
We did it ! A special screw and a tweezer and it's (almost) like brand new.
Thanks a lot ! I was so desperate...
Merci merci merci ;)
 

Attachments

  • 20181223_104222.jpg
    20181223_104222.jpg
    1.2 MB · Views: 11
  • 20181223_104230.jpg
    20181223_104230.jpg
    939.4 KB · Views: 11
  • Like
Reactions: Boareserke

Latest threads

Members online

Forum statistics

Threads
4,134
Messages
37,700
Members
5,533
Latest member
dmayer39