Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Firmware, bluetooth and flying issues

WolfSpring

Member
Joined
Jun 19, 2020
Messages
7
Reaction score
0
Location
Hawaii
I picked up a Rolling Spider on eBay for $20 just the drone and battery and it appears to work. I've been searching for answers, but first it connected, tried to fly, crashed and when I tried to reconnect it wouldn't, I found this was a known issue, after a lot of playing around and reading I found how to make it connect often enough to try and fly, but it drifts either to the left on take off or straight forward. I thought it was the props so I switched them around and still the same issue, swapped them with good props exact same thing, mainly left. Blew off the sensor didn't see anything on the camera.

I then tried to update the firmware, from the phone is a no go, won't stay connected to upload. I followed instructions for USB, acts like it completed, but the firware in the phone shows the same, even on a different device first time connect 1.03 instead of 1.99. So I'm at a minor loss here. It was listed as is for parts so I'm glad it even powers on and I know it's old, outdated and unsupported, but I figured I'd give it a try. This should perform like the mambo from what I've seen and it doesn't get an inch off the ground before it drifts crazy.
 

Skydreamer

Well-known member
Joined
Jun 30, 2018
Messages
458
Reaction score
174
In freeflight mini settings,is there Flat Trim button,if there is one rolling spider should be placed on flat level surface and flat trim button should be hit once or twice to reset all sensors...it should be done before every take off,usually fixes drift problem...also make sure you are 3 feet/1meter above anything or it will drift like crazy.......flat trim and reset are only two things you can do to attempt to fix problem
 

Attachments

WolfSpring

Member
Joined
Jun 19, 2020
Messages
7
Reaction score
0
Location
Hawaii
In freeflight mini settings,is there Flat Trim button,if there is one rolling spider should be placed on flat level surface and flat trim button should be hit once or twice to reset all sensors...it should be done before every take off,usually fixes drift problem...also make sure you are 3 feet/1meter above anything or it will drift like crazy.......flat trim and reset are only two things you can do to attempt to fix problem

Yeah I just wasn't flying high enough. It worked great after than then I crashed it and a prop is too loose so I need to get some more props, but it's a good little drone for $20.
 

Latest threads

Members online

Forum statistics

Threads
3,965
Messages
36,035
Members
5,296
Latest member
Pietkin