Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Lost connection

PGTART

Well-known member
Joined
Mar 15, 2019
Messages
54
Reaction score
9
Website
www.peterboos.tk
I did a first test flight, and have connection problems since.

At first without flying i connected directly to my mobile and took photo's only, that worked.

Then turned everything off, connected the controller to the phone (with a usb connected sound), turned on the drone ... unable to connect. Pointed directional antena towards it but no connection.

So i went back to the phone only (without controller).
A first flight, it worked ok, I did fly, I recorded a test video and did basic manouvring in slow filming mode.
But then i lost video link (although the drone was still responding to flight commands)
So I went to the FreeFlight 6 app and clicked 5G (hoping for less interference).
Since then i have no connection anymore with the drone's wifi.
Mobile wont find it, it doesnt seam to broadcast, cant set it back to the default wifi either.

Any advice on this ?.
 
Last edited:

Krusty Geeza

Well-known member
Joined
Dec 31, 2018
Messages
733
Reaction score
413
Location
Adelaide, South Australia
Website
alexmausolf.com
When you use the controller you need to turn off your phones wifi by going into Aeroplane mode. Is that what you are doing when using the controller?

Are you doing this indoors? If so, is there a wifi booster or wifi router nearby? That could potentially play havoc with signals.

There's so many variables possible here, I'm just going to suggest the simplest option which is to reset the Freeflight 6 app preferences.

  • Open Freeflight 6 app
  • Click the cog on the top right of the screen
  • Scroll to the bottom of the screen
  • Click "Reset All Interface Preferences"
Job done! :)
 

PGTART

Well-known member
Joined
Mar 15, 2019
Messages
54
Reaction score
9
Website
www.peterboos.tk
I tried your steps but no succes, it seams this drone isnt advetising its network.
I dont know what it means but the controllers led blinks bleu white bleu white bleu white.
it wont show back up on 2.4GHz network either, and its not listd on 5G as well.

in the freeflight app all network buttons are grayed out now (whilst in aeroplane mode)

Also i tried reset holding power button 10 sec no succes either.
I checked the card for some .txt file (dont know how it should be named) but from another post i red that it would contain network config for the anafi on the SD card, there was no such file (but unsure it it should have been on the card)
 

PGTART

Well-known member
Joined
Mar 15, 2019
Messages
54
Reaction score
9
Website
www.peterboos.tk
Are you using the controller here? I meant my instructions to be followed when you use your phone in conjunction with the controller.

Yes i tried with controller and without (the controller wont show a continous bleu led though, so i doubt it connects).
 

Krusty Geeza

Well-known member
Joined
Dec 31, 2018
Messages
733
Reaction score
413
Location
Adelaide, South Australia
Website
alexmausolf.com
Another update after a few resets ( Anafi no wi-fi signal ) now the drone wont turn off, seams broken on first day
When you say reset, do you mean holding the power button until all four indicators flash red?

Is everything fully charged?

Without actually seeing what is going on, I really can't assist much, I'm afraid.
 

PGTART

Well-known member
Joined
Mar 15, 2019
Messages
54
Reaction score
9
Website
www.peterboos.tk
It was about 50 percent I guess it didn't turn off eventually I had to remove the battery sins the the drone didn't respond. It's charging now I wait till its fully charged.

I wonder should there have been a wifi configuration file on the sd card since I cannot find such a file got only movie and bin files on it.
 

jefmob_1

Well-known member
Joined
Jul 27, 2018
Messages
87
Reaction score
40
Age
60
Location
Switzerland
did you use the right USB cable?
One not only for loading but for data transfer.
 
Last edited:

PGTART

Well-known member
Joined
Mar 15, 2019
Messages
54
Reaction score
9
Website
www.peterboos.tk
Yes i had multiple cables with me, if a wrong cable is pluged in the mobile keeps making usb connect sound (like a windows pc usb connect sound). Small progress after a full battery the drone responded again to the on off button.

However its still not broadcasting a SSID , i used wifi scanners on my phone but its not broadcasting.
If anyone here can tell me if it possible to put a wifi kinda config file on the drone, to enforce it a certain wifi config pls let me know.

I also wonder if there is a way to hard reset the drone (ea pressing on switch 12 sec doesnt do the job).
 
Last edited:

PGTART

Well-known member
Joined
Mar 15, 2019
Messages
54
Reaction score
9
Website
www.peterboos.tk
Had some luck today, turned the drone on, waited till it seemed ready.
Then pressed power button for about 8 seconds, the green leds one by one go red.
I stopped pressing the button when all buttons tail led got red.

This resulted in the anafi writing its wifi password to disk AND ALSO IT WENT BACK TO 2.4 Ghz !!!!
Now that that worked, through the mobile app i put it back to 5Ghz wifi and took manually a free channel.
That, of course, broke current wifi connection from the phone, so i tried scanning for it ..nada nada no drone there.
So pressed again 8 sec till all leds got red and it went again back to 2.4 Ghz. (glad the trick works).
My phone a Samsung GTi93011 can work on 5 Ghz so not sure why it doesn't see the drone there (used it often).
Wel at least the phone works on 2.4Ghz with anafi, thats better then nothing..

However, the controller still doesn't connect with the phone although it now seems to connect to the Anafi (led turns blue).
And when I turn of the drone it starts blicking "bleu-white" repeatedly, proving I guess that a blue led must mean connection.
( after work i'm at home so i will not give commands to fly the drone indoors, outdoors is night now (long workday))

I'm not sure why the controller behaves like this, apparently, it gets on the Anafi wifi network, but fails camera communication.
As if the controller itself needs another protocol, as if it needs some update too, or is an update behind?
When I tested the drone the first install was with mobile (as there was no manual included, it seemed safe) now i do wonder if maybe that was wrong ? (not sure).
I wonder how to update the controller if that is possible (and if i'm right on this).
 

PGTART

Well-known member
Joined
Mar 15, 2019
Messages
54
Reaction score
9
Website
www.peterboos.tk
Have you followed these instructions to the letter?

No see them for the first time. A warning paper in the box would have been handy. Box contained minimal guides.

So I guess remove software from the phone and reinstall ? (Although the anafi is all ready updated) or do they have a pc based upgrader for the controller?
As a programmer I think that would be the easiest way.
 
  • Like
Reactions: Krusty Geeza

Krusty Geeza

Well-known member
Joined
Dec 31, 2018
Messages
733
Reaction score
413
Location
Adelaide, South Australia
Website
alexmausolf.com
No see them for the first time. A warning paper in the box would have been handy. Box contained minimal guides.

So I guess remove software from the phone and reinstall ? (Although the anafi is all ready updated) or do they have a pc based upgrader for the controller?
As a programmer I think that would be the easiest way.
When I bought my basic kit there was the "Super Quick Start Guide" included, but I did find these instructions on Parrot's site & have them bookmarked prior to purchase. I stumbled on them via part of my obsessive internet research prior to purchase, as I was deciding between the Mavic Air & the Anafi. I don't regret my decision!

I would suggest removing the FF6 software, rebooting the device & reinstalling again, then follow the instructions.

I don't think they have a PC upgrader & I don't know that they ever will. I saw some astounding statistics from a recent technology use study showing the rapid decline of PC's for personal use over the last few years with shifts to phone & tablet use as a predominance for people on the whole! Call me a philistine, but I love the visual real-estate of my calibrated 27" monitor for photographic & video editing. You can pry it from my cold, dead fingers... :giggle:
 

PGTART

Well-known member
Joined
Mar 15, 2019
Messages
54
Reaction score
9
Website
www.peterboos.tk
PC's are rapidly in decline because anyone has one, so selling them is harder, they still dominate the work area though.
Personally i prefer heavy power laptops 17 inch, (mainly i use it for video editing, and blender 3d, and visual studio, gimp)
Those will never work good on a mobile / notebook /watches.

There is another tendency though that it doesnt matter anymore for what platform you code for.
Apple, linux, windows, mobile, web, desktop.. all can use .net core and c++, GO, Python etc.
Tomorrow i will try your steps (and thanks for the info).

I was indeed a bit suprised how minimal the packaging was (i even wondered it was a repaired one), lacking a good manual, lacking clear directions of what to do.
So my plan was to go for mobile first since i often use it too for investigating wireless issues and this was a wireless device.
I think for the price maybe a good readable color manual, would reduce them user support (or a yellow note with: 'dont panic' browse this url first )
 

Dirk_ANAFI

Well-known member
Joined
Aug 7, 2018
Messages
1,301
Reaction score
525
Location
NRW, Germany
Perhaps these links can be helpful:
 

PGTART

Well-known member
Joined
Mar 15, 2019
Messages
54
Reaction score
9
Website
www.peterboos.tk
Had some time yesterday, installed the controller, by re-installing the software on the mobile.
However the controller battery was at 40% or so, and the installer not realy liked that (it never finished the install circle).
Then i charged, again kinda same problem, but i just closed the lid after 10 minutes ( as i had green led on the controller, i asumed upload install worked).
Restarted phone, conected in airplay mode, connected controller opened it, and it showed proper version, and everything worked.
Through the controller set it to 5G, no connection loss.
I did not yet fly as it was again night, but camera control worked.

(kinda funny those stabalizers you alter camera angle towards somthing but the gimbal keeps it old position, a new era in filming experience opens up).
 

Latest threads

Members online

No members online now.

Forum statistics

Threads
4,948
Messages
43,235
Members
7,129
Latest member
estudiocad