Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

SkyController not connecting to Drone

bongi69

New member
Joined
Oct 25, 2018
Messages
1
Reaction score
0
Hi All,

So since Friday I've had an issue whereby my controller will not connect to the drone.

I flew it at a wedding to get a group shot, came in to land and left the drone powered on for about 10 mins (sky controller was also on) while I got other shots before I was able to pack it up. Before I powered it off I still had a connection.

I went to use it today but the sky controller will not connect to the drone. The light on the controller & drone just flash as if waiting for connection.

So far I have done all of the below to no avail:
- Hard reset of the drone
- Tried different batteries.
- Tried connecting the USB C cable from the controller directly to the drone (the controller LED will flash green a few times when doing this)
- Reset the controller
- Once reset I tried to pair the controller to the drone. The drone will show as available, when you click on it to connect it will ask for the wifi password & successfully accept it but then will just say "connecting" and doesn't connect.

Connecting my phone to the drone using the drones wifi AP works fine and I am able to pilot & see the camera footage, but the sky controller will just not connect no matter what I try.

I've lodged a ticket with Parrot but in the mean time can anyone think of anything I can try to try restore connection, as I need to use it again on a job this week.

Thanks!
 
Go into the FF6 app with the controller connected to your phone/tablet. The controller icon upper right should be lit. Tap on it and get into the Skycontroller 3 page.

Look at the options: connect/calibration/reset.

Go through these three selections with Anafi powered and it should get the controller and drone talking to each other.
 
Last edited:

Members online

No members online now.

Forum statistics

Threads
5,368
Messages
45,450
Members
8,167
Latest member
bandylamb