Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Balance Charge bebop 2

Swordfish

Well-known member
Joined
Nov 5, 2020
Messages
48
Reaction score
6
Hello guys
Iam having problema yo balance Charge My bb2 batteries. I have just bought an hota d6+ and some custom cables that an ebay guy sold me. Thing is that i get an error in the Charger screen.
The charging funciona works but without connecting the balancer cable to the Charger, but when i connect ir i have an error "Too high balancer Port voltage" Any ideas?
IMG_20210426_223044.jpg

IMG_20210426_223056.jpg
IMG_20210426_223415.jpg
 

Quadbod

Member
Joined
Feb 27, 2021
Messages
6
Reaction score
2
Location
Suffolk, UK
Hi Swordfish,
I'm not sure how new you are to all this, so please forgive me if some of the following seem oversimplified or blindingly obvious, but this is what I'd be checking (I was doing the same as you, only mine's an IMax B6 charger):

1 Is it a genuine Parrot battery or aftermarket (A/M)?

Parrot batteries have an internal balancing PCB, this may conflict with the Hota charging system. A/M ones don't, which is why we need the balance charger/cable setup you have here. Someone here more knowledgeable may be able to confirm this, but if it's a Parrot battery, I think you only need the main power connected (the XT60), or if you must connect the balance cable, select "charge", not "balance charge"


2 Is the battery known to be good? (no sick/dead cells)?

check this link for a similar problem to yours:
https://www.arrmaforum.com/threads/...lancer-port-voltage-error-message-help.26898/


3 Have you checked the cable is made right?


First thing I did with mine was check for incorrect connections & shorts (pic)

BB2ChargercableDiagram.JPG
4 Does the charger definitely work?

Unlikely, but possible it's faulty. Does it work ok it with other (standard) 2/3/4S batteries eg from RC plane/car/FPV?


5 Are you plugging the cable into the battery the right way round?

Some cheap A/M plugs may fit both ways (I had to label mine! -pic)

CablePlugOrientation2.jpg

6 Can you measure the indivdual cell Voltages & resistances on the charger?


Then at least we can suppose all the connections are ok,
Can't Hota tell you what conditions cause that error message?

Hope this helps. If you want me to duplicate any part of the process with my setup for comparison, please let me know.

Also, you could reach out to AnthonyVLOG - he's a wizard with BeBops and technically very skilled. He's done loads of battery tests + experiments, and may know the answer to your problem:

YouTube Channel:
https://www.youtube.com/channel/UCGDzirr_waz6gzxyiLDFcHA/featured

Facebook Group:
Facebook Groups

Good luck

Regards
Gareth
 

Latest threads

Members online

Forum statistics

Threads
4,404
Messages
39,891
Members
6,026
Latest member
AHIL