Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Bebop 1 and skycontroller ... Drone flies... but app and firmware update issues


New member
Apr 22, 2024
Reaction score
Hi, i had a bebop 1 with SC years ago and it worked fine.

I bought a second hand one recently because it was a great price. However having issues.

I can connect the drone to the SC and fly it that way. However i really want to use the app for obvious reasons.

The freeflight 6 app has no joy (since found out that doesnt support the bebop 😫)

Downloaded the freeflight pro apk. Version 3 and 5. But app saying 'synchronisation failed' check internet connection (even though the internet is fine). Cant connect direct to drone or usb connected to the skycontroller...

Have tried to update firmware on both. Small usb stick fat32 formated, file in the root directory, but nothing happens. The drone just sits there humming. And no prompt comes up on the SC interface screen either when usb is inserted. Any ideas? Is there another app i can use? Am i making a rookie error withnthe firmware update? Shall i just bin it and buy a newer drone? 🤣
You need to install FreeFlight Pro with the obb directory or you will continue to get the "synchronization failed error". There's a guide here:


New Posts

Members online

No members online now.

Forum statistics

Latest member