Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Bebop Telnet Issue

Terrafir

New member
Joined
Feb 18, 2024
Messages
3
Reaction score
0
I am very interested in getting the GPS data from my Bebop 1 and mapping in a GIS tool. I understand that this could be possible.

I am trying to connect to my Bebop over telnet. I successfuly did this by turning my drone on, and then clicking the power button 4 times after the initial light flashes.

I was able to get the GPS flight data, but I believe I went a little too far with my customizations and now I cannot factory reset the Bebop. I added these scripts to the `/bin/onoffbutton` directory and followed the instructions. I even copied the existing `onoffbutton` contents to a `onoffbutton_backup` directory.

However, I believe in that repo there is a `verylongpress_0.sh` file that has overriden the default `verylongpress_0.sh` file. Now upon holding down the Bebop's power button for 10seconds, the bebop does not factory reset. I am no longer able to access the Bebop over telnet either. I have connected to the Bebop via an FTDI cable and looked at the output. When I hold down the power button for 10seconds (expecting a factory reset) I instead get:

Code:
boxinit: untracked pid 1245 'longpress_0.sh' exited <--- interesting as this should be verylongpress_0.sh
boxinit: untracked pid 1244 'BLDC_Test_Bench' exited

Even more annoying is I can no longer turn the Bebop off by pressing the power button. Instead I have to remove the battery pack...

Does anyone have any suggestions on how I can fully factory reset this Bebop so I can get Telnet access again? I have tried upgrading the device over ftp on port 51 - yet I'm unsure that it actually is working ( the upgrade file is removed after I restart the Bebop), but the firmware version does not change when I access the FreeFlightPro app.

I would really appreciate any suggestions on how to resolve this. I'm a software developer by profession and am fine with some complexity when told where to look.
 
Have you tried finding an old firmware update and updating the firmware via USB thumb drive?
 

New Posts

Members online

No members online now.

Forum statistics

Threads
5,335
Messages
45,303
Members
8,104
Latest member
tiktoksss7890