Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Mambo Refusing To Update

Clarky3rdNut

Member
Joined
Jan 30, 2019
Messages
7
Reaction score
0
Location
Bath, UK
Hello all,

Brand new to the forum and hoping you can help me.

I have an early Parrot Mambo (Pilot & Play from 2016). It is on software version 2.6.6 and refuses to update.

I open FreeFlight Mini and once connected to the drone, the 'Update required' message begins flashing.

If attempt to update via Bluetooth, after approx. 5 second I receive the error: "Error during sending firmware to drone" with a separate message:
"Step description, Error happened while firmware was sending to drone" from the iOS FreeFlight Mini app or,
"Step description, Mambo 2.6.6 -> 3.0.25" from the Andriod FreeFlight Mini app.

Updating from a PC goes through the motions of appearing to work. Whilst transferring the file, the lights on the Mambo blink orange.
Upon disconnecting the drone, one orange light blinks only very briefly before returning to the pair of blinking green lights, waiting for the Bluetooth connection.
Once paired to FreeFlight Mini however, I still get the message that an update is required and the software version is still showing as 2.6.6

I have contacted Parrot customer support with this issue and they have so far been fairly useless.
They have sent me two different update .plf files and keep repeating the same update instructions. They do not seem to take into account my descriptions, screenshots or short videos that I have been sending them of the updates failing.

I am now at the point of giving up with the Mambo and throwing it away. It is a shame really, as I was keen on buying the FPV upgrade for it.

My last hope is that some knowledgeable sole(s) on here can help. Keeping my fingers crossed!

Many thanks.
 

Dirk_ANAFI

Well-known member
Joined
Aug 7, 2018
Messages
1,087
Reaction score
433
Location
NRW, Germany
First:
- You have FF Mini v5.5.3 up and running?
- You have downloaded the actual firmware version 3.0.26 from here:
Dropbox - Mambo.plf
- You know how to update the Mambo Firmware with the USB method?
 

Clarky3rdNut

Member
Joined
Jan 30, 2019
Messages
7
Reaction score
0
Location
Bath, UK
Hi Dirk, thank you for responding.

So it seems I am running FF Mini v5.5.8 as this is the latest version on the Apple AppStore.

Since joining this forum today, I have downloaded and attempted to update to version 3.0.26 from the link available in the 'Thanks for Mambo subforum' topic.
Unfortunately, I am getting the same problem. I have followed the instructions of updating via USB to the letter and it just does not seem to work.

When I disconnect the USB cable after transferring the file to the ROOT of the drone, both lights will blink green for a short while, then the lights will alternate orange, but for less than two seconds before they both return to blinking green, awaiting the connection to FreeFlight Mini.

It is almost as if the drone is updated to the latest version but the app just isn't recognising it. I have deleted and re-downloaded the app, and even tried it on an Android app to no avail.
 

Dirk_ANAFI

Well-known member
Joined
Aug 7, 2018
Messages
1,087
Reaction score
433
Location
NRW, Germany
... less than 2 seconds ...
The update should last longer: about 1 or 1.5 minutes if I remember well.
After the "update": is the Mambo.plf file still in Mambo's root directory or is it empty?
The update should be successful, if the file is gone.
If you choose the drone box on the startup screen of FF Mini: which "Software-Version" and "Hardware-Version" are shown there?
 

Clarky3rdNut

Member
Joined
Jan 30, 2019
Messages
7
Reaction score
0
Location
Bath, UK
I’m not sure if the 2 second flicker of orange light is what would happen if attempting to update a drone that is already at the latest software version?
Once the update process has finished, the Mambo.plf file is gone, as if the update was successful.

Software Version: 2.6.6
Hardware Version: HW_02
 

Dirk_ANAFI

Well-known member
Joined
Aug 7, 2018
Messages
1,087
Reaction score
433
Location
NRW, Germany
Normally the app should read the firmware version correctly after the update. So I am not convinced you have the actual FW.
My hardware version is HW_12, but your hardware should be able to use the new FW as well. At least I know, that HW_02 was able to run FW 3.0.17.

So next I would try two things (each with iOS smartphone first, then if no success Android), BEFORE each of these make a …

Factory reset:
1. Switch On Mambo, and wait for the LEDs to turn green.
2. Press the Power button again and keep it pressed for about 30 seconds. During this period:
- a. The two LEDs turn red alternatively and start blinking.
- b. The frequency of blinking increases indicating the last stage of the reset process.
- c. Keep the Power button pressed until the LEDs turn green.
… and clear the app's data (Android settings, don't know if this is possible with iOS).


First thing:
Update again with actual FW 3.0.26 with USB method. Be sure to have a fresh and fully charged battery. Disconnect USB shortly after copying the FW to Mambo's root directory. WAIT long enough to complete the process without doing anything. Two seconds is not enough.

Second thing:
Only if the first try was NOT successful, update again (after factory reset …) with older FW 3.0.17.

If successful: Now try the first thing (FW 3.0.26) again.
If not successful: lets see, if we still have more ideas … :unsure:
 

Clarky3rdNut

Member
Joined
Jan 30, 2019
Messages
7
Reaction score
0
Location
Bath, UK
First of all, I would just like to say Dirk, thank you for your awesome support so far!

Secondly, I will try the above today -I have attempted factory resets prior to updating before, without making difference. Nevertheless, I will follow your above instructions precisely and report back.
Before I do however, do you know where it is possible for me to download FW 3.0.17 from?
 

Clarky3rdNut

Member
Joined
Jan 30, 2019
Messages
7
Reaction score
0
Location
Bath, UK
Ok so I have attempted both things as mentioned above.

After updating on these attempts, I waited until the Mambo switched off automatically, despite the lights only remaining orange for a second or two. Each time however, still resulted in the software version displaying as 2.6.6
This is from both Android and Apple devices. (Indecently I did clear the data from the Android app but this doesn't appear to be possible from iOS).

I then attempted exactly the same, using the older FW 3.0.17 - Unfortunately, still no joy.
The only interesting point to note is that update 3.0.17 results in the RH orange light illuminating for about a second. Update 3.0.26 results in the RH orange light illuminating for about a second, followed by a quick flicker of the LH orange light.

Alas, after updating to either 3.0.17 or 3.0.26, both iOS and Android FF Mini apps claim that my Mambo is still running version 2.6.6

Just to be clear, before attempting any update, I made sure that the battery light was green and performed the factory reset process, holding the power button down until the lights changed from fast alternating reds back to dual blinking greens.

I am unsure of the FW update history for these Mambo's. Were there many updates between 2.6.6 and 3.0.17? Could it be worth trying to get hold of all the ones in between and attempting to update the drone in sequence of the update releases?
 

Dirk_ANAFI

Well-known member
Joined
Aug 7, 2018
Messages
1,087
Reaction score
433
Location
NRW, Germany
Doesn't sound good so far!

Yes, the history of your Mambo becomes interesting: Was it owned by someone actively changing anything in the drone's firmware? We don't know.

My ideas are now on the way to run out … :(
What I still would try:

1. If you are able contact the seller or former owner of your drone: ask him whether he changed anything in the drone's firmware. If yes: tell him to install an original FW or to take it back.

2. Try to clear Mambo's memory as described here. This a stony way, because you have to install a RNDIS driver on your PC and have to deal with Telnetting (directly reading from / writing) into the drone.

3. As you already suggested: try the FW versions between 2.6.6 and 3.0.17. I know of two versions: 2.6.11 and 3.0.6. I don't want to post them here in the forum, but you could send me your E-Mail address via PM. Then I will send you these 2 versions. You should try these updates with the USB method, but also over the FF Mini app.

4. If the USB method has definitely no success, you could try to update again over the Freeflight Mini App using older versions of the app. They are hosted here (Android). Download the APK file, uninstall the actual FF Mini version and install the older version like every Android app. In settings of your phone you have to allow installing apps from unknown sources before. I think, the FW 2.6.6 is from 2017, so I would start with the app versions of this year.

5. If you know someone, who has the Mambo FPV: Perhaps he lends you the FPV cam for a while. Then you could try everything to make the update over the app: The data transfer for the update now runs over the cam (that means WiFi) and perhaps overruns the actual problems. Just a speculation ...

6. [… ran out of ideas ...]
 

Clarky3rdNut

Member
Joined
Jan 30, 2019
Messages
7
Reaction score
0
Location
Bath, UK
Some excellent suggestions yet again Dirk. Thank you.
I will give them a go this evening and report back tomorrow.

In the meantime, I just wanted to pass on that I am the original owner of the drone.
I have enjoyed using it many times but it didn't really make it out of the cupboard during 2018
It was the news of the FPV kit that prompted me to blow the cobwebs off and get it going again. Unfortunately, this is when I discovered it didn't want to get going again!

I will PM you my email address. I am hoping those previous FW versions and the previous FF Mini app could be key!
 

Clarky3rdNut

Member
Joined
Jan 30, 2019
Messages
7
Reaction score
0
Location
Bath, UK
Just wanted to report on some developments.
The snow has made it here so, with a day off work to enjoy it with the kids, there won’t be much time for playing with the reluctant drone until later.

However...

Last night I installed V4.2.4 of FF Mini onto my Android device, using the link kindly provided above.
This older version of FF Mini, despite recognising that my Mambo is at 2.6.6 and “recommending” an update, allowed me to fly my drone. Yes it actually flew!!
I attempted to update over Bluetooth using ‘old’ FF Mini and, no surprises, it failed.

At least this is a glimmer of hope. The drone operates and flies. Just something is causing it to collapse during the FW update.
I think I will attempt to clear the memory later using the Telnet method.
 

CPDiehl

New member
Joined
Aug 8, 2019
Messages
1
Reaction score
0
Hi, I am in the exact same situation with my original Mambo and several unsuccessful attempts to update using FF on iOS.
Did you ever find a solution earlier this year ?

Thank you!
CP
 

Dirk_ANAFI

Well-known member
Joined
Aug 7, 2018
Messages
1,087
Reaction score
433
Location
NRW, Germany
Just to compare with the case described above:
What is your HW version?
What FF version is actually running and which version do you want to use/update?
Which software version?
 

Riki

New member
Joined
Nov 17, 2019
Messages
3
Reaction score
0
Hello guys,

Any real solution yet? I have the same problem. Mambo Parrot Fly with hw_02 and sw 2.6.11 that does not want to update.
Its brand new. It flew 1 time right out of the box, and now it keeps asking for the update.
Bluetooth update gives the error message and USB method just results in nothing.
I've tried different computers, different ports, different cables, different FW versions ...
Is there another way to install the software, not using the pfl file.
Any help is much appreciated.
 

Riki

New member
Joined
Nov 17, 2019
Messages
3
Reaction score
0
5. If you know someone, who has the Mambo FPV: Perhaps he lends you the FPV cam for a while. Then you could try everything to make the update over the app: The data transfer for the update now runs over the cam (that means WiFi) and perhaps overruns the actual problems. Just a speculation ...

Hello Dirk,
Could you please elaborate on this?
 

Latest threads

Members online

Forum statistics

Threads
3,043
Messages
26,048
Members
3,994
Latest member
helmutk