Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

1st flight issue. FreeFlight App keeps crashing...

Razor62

Member
Joined
Dec 24, 2018
Messages
9
Reaction score
3
Hi folks! Just got my Bebop 2 charged it up and calibrated the drone. was able to connect to the app and press launch. The drone did as was expected. It lifted off and began to hover a couple of feet above the ground. However, as soon as the drone gets airborne the app crashes. I'm running the app on my Galaxy S8 phone. Is anyone aware of any know issues with this phone and the Freeflight app or am I doing something wrong?
Thanks in advance,

Kevin
 

Razor62

Member
Joined
Dec 24, 2018
Messages
9
Reaction score
3
Answered my own question. Went back to Google Playstore and started reading reviews on the FreeFlight APP. Seems there's a compatibility issue with the software and Android 9 which is what I'm running. There are numerous negative reviews with exactly this issue. ****!!!!
 

Skydreamer

Well-known member
Joined
Jun 30, 2018
Messages
459
Reaction score
174
Hi,if you have old android phone(5,6 or 7)try using it,there is no issues that i know with this versions....android 8 has telemetry issue,as long you fly with your phone installed on skycontroller 2 you are fine,if you switch to FPV(glasses )you loose telemetry(no on screen info)....this is ongoing problem with since april this year and it is still not fixed...it looks like parrot is more focused on Anafi ,how long it will take to fix android 8 and 9 issues nobody knows
 

Razor62

Member
Joined
Dec 24, 2018
Messages
9
Reaction score
3
Thanks so much for taking the time to explain all that. Switched to a tablet for now and I'm in the air.
Funny thing though, this afternoon I was able to connect my phone to the drone but this evening the phone said connected but the app said no connection...Tried restarting the app the Bebop and the phone several times but nope. Was gonna try the Air controller but the app had other ideas... Pretty weird...
 
  • Like
Reactions: Skydreamer

Razor62

Member
Joined
Dec 24, 2018
Messages
9
Reaction score
3
Thanks guys! Anyone know if installing an earlier version of FreeFlight Pro will resolve the issue? Turning off mini mapping does not correct the problem. I still can't use the tablet stand alone. It must be connected to the Sktcontroller2 in order to work at all.
 

Latest threads

Members online

Forum statistics

Threads
3,976
Messages
36,113
Members
5,317
Latest member
OtisG