Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

No camera feed, now won't start

hiero

New member
Joined
Mar 13, 2021
Messages
3
Reaction score
0
I had the same problem as in this thread, where everything was working fine except the camera feed was black (iOS) or static snow (android):

My drone is out of warranty, etc so I figured I had nothing to lose to open it and try to fix it myself. I thought the sd card mechanism was a flimsy cop out but....Holy smokes, the connections for these ribbon cables are a fail design for something that has to fly around.

So long story short, I disconnected and reconnected the ribbon cables once, same problem with no camera feed, then on the second try the drone would no longer power up. The exhaust fan will power up for a fraction of a second when inserting the battery, but that's it. Pressing the power button on the battery after plugged into the drone only behaves the same as when the battery is not plugged in (led charge indication). Does anyone know if this means I fried the board somehow or could I have disconnected something else with my tinkering? I'm wondering if it's even worth messing with it anymore and just saving/selling it for parts? I would like to get another Anafi, I was pretty happy with it, but after seeing the inside I'm not so excited about any more Parrot stuff.

drone.jpg
 

Saladshooter

Well-known member
Joined
Jan 29, 2021
Messages
53
Reaction score
11
Location
Connecticut
Its probably still a loose connection or two.... black camera feed is usually a loose ribbon cable somewhere.... it can be on the camera itself which is inside the camera casing or on the board.....

Check everything, it is still probably something simple... and don't despair.

If you give up.... they sell for good money on eBay even broken. And I can buy a used or refurb fully working for $350-$400 on Mercari, Ebay or Amazon on most days.
 

hiero

New member
Joined
Mar 13, 2021
Messages
3
Reaction score
0
buy a used or refurb fully working for $350-$400 on Mercari, Ebay or Amazon on most days.
That's the thing, the level of ***-grabbing needed with these ribbon cables and the plastic clip is off the charts but I was willing to give it a go to fix the camera feed. Now that the drone won't even properly power up, I'm not even sure where to start (unless this could also be a ribbon cable connection problem) and possibly the board is bricked anyways.
 

Saladshooter

Well-known member
Joined
Jan 29, 2021
Messages
53
Reaction score
11
Location
Connecticut
You have most likely dislodged the battery to mainboard connection causing the power-up problem. Often you can carefully seat it again if it is just loose using a tool like a plastic dinner knife. One end is in the center of the motorboard and the other is on the mainboard.

If you can get that going... check the ribbon connection inside the camera housing for the camera feed issue. its just as fragile connection as the rest of them and hidden away.
 

hiero

New member
Joined
Mar 13, 2021
Messages
3
Reaction score
0
You have most likely dislodged the battery to mainboard connection causing the power-up problem.
Thanks! I'll give it another go, at least once. I don't want to give up too early if it's not so easy to blow the mainboard.
 

Latest threads

Members online

Forum statistics

Threads
4,404
Messages
39,890
Members
6,025
Latest member
Mposco