Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Parrot Anafi Gimbal Glitching


New member
Dec 15, 2021
Reaction score
Hi all

I bought a Parrot Anafi that’s been damaged. The guy flew it into a tree and managed to break one of the back legs. I’ve replaced the legs and everything else on the drone seem in great condition.

However, the gimbal was unable to calibrate before I got the new legs and is still going the same. I’ve followed various threads and tried many of them, including removing the camera cover, anything blocking it or if the camera might be knocking somewhere.

When I attempt to calibrate, it gives me the usual “place on flat surface”. After a few tries, it’s as if the gimbal dies completely as you can move the camera around freely and the app tells me the calibration option is unavailable. In flight mode, it gives me the yellow message and after the gimbal dies, it says I need to restart the drone.

While trying to calibrate, the camera moves to the top 2 corners without hassle. It seems as if the crossing over to the bottom is where it stutters and usually gets stuck and kicks the camera to a random position. If I do nothing, the calibration fails and the camera would make small movements at random.

The gimbal itself looks in good condition with no damaged or bent parts. It moves at ease except for the extremely light tick I feel when moving the gimbal up and down.

Ive tried to add a video of the gimbal glitching, but wasn’t able to. When the gimbal is active (without calibration and failing) and I tilt the drone up and down, the gimbal works and keeps the camera in the same direction. However, it stutters when it gets to the forward facing area. It would still keep the camera steady in one place, but shakes a bit. If I tilt the drone all the way up or all the way down, it’s as if the gimbal loses a lot of power as the camera would drop to the left or right. If I tilt it back to going flat, the gimbal kicks in again and keeps the camera steady.

Hope someone has some tips and tricks. I’ve done resetting via the app and the battery button. Using the latest software on both the controller and drone, updated less than a week ago.

Also, I’m unable to take off or fly the drone at all. Is this due to the camera not calibrating?


  • EC6431AB-BA55-447C-9B5A-9EEECFC30365.png
    201.3 KB · Views: 24
  • 59495D80-2B47-499B-9A13-DFD265CCBEAD.png
    3.2 MB · Views: 26
  • 6A71AD0A-E12F-4A17-9C23-61B4416FAC1D.png
    3.1 MB · Views: 25
Hi @RayzParrot

It sounds like the gyroscope might've been damaged in the crash.
Also I'm not exactly sure but replacing the leg might be similar to Apple products, where each piece of equipment has its own code that connects and doesn't accept modified parts. This is probably so that people don't get around the custom build / modified restrictions and pretend it's stock.

Keep us updated and best of luck.
You are fine replacing legs, they are not locked to any serial or code, many have changed these.

With regards to the camera. If its been in a crash its possible the fork that holds the camera could be ever so slightly buckled,

Try taking the outer shell of the Camera off, its a simple process. Then try and see if you can calibrate it.

A good few people have had a similar situation.

Good luck
  • Like
Reactions: Liger 1956

New Posts

Members online

No members online now.

Forum statistics

Latest member