Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Bebop flashing green light

rabbit_uk

Member
Joined
Mar 7, 2024
Messages
6
Reaction score
1
I've just been given a Parrot Bebop 1 (version 2.0.29) in an unknown state. The old batteries were puffy so I've cut off the terminals and purchased some XT60 1500mAh 3S LiPos to use with the drone. The battery voltage is just factory at the moment (3.8v cell voltage) - not the highest but I would think it is enough. When I attempt to turn on the drone all I get is green flashing light. There is no noise or movement (neither fan nor quad blades). I see no WiFi network appear. I can feel the board getting warm so don't leave it on for more than a few minutes. On the serial port on the LHS near the battery connector, I measure 3.2V from fore pin (ground I believe) to either of the other 2 pins. The voltage doesn't seem to move which suggests to me that nothing is being transmitted over the port. I wonder if somebody else has come up against this and I wonder what I should look at next.
 
Last edited:
Have you factory reset it?

"You can reset the Parrot Bebop Drone to factory settings. To do this you need to press and hold the power button for 10 seconds"
 
I probably tried before, but I've just tried this again but consciously and it doesn't appear to make any change to the green flashing light. According to the 'Bebop Hacking' PDF I have, the light sequence should change during a factory reset.
 
The Hacking PDF is accurate. I just reset one today though, had to hold it longer than 10 seconds (or what felt like longer) then it went into the factory reset/light sequence. I didn't let go of the button until it was clear the sequence started.
 
Ah, great you have a Bebop at hand!

I've had the button pressed for 20 seconds and no effect. Does the motherboard fan come on immediately you switch on the drone? Or is it switched either electrically (analogue) or via the microcontroller? I don't hear any fan at all but do feel the board getting warm. Wondering what might be preventing the boot up from completing.
 
Last edited:
Sorry, I need to clarify, the one I factory reset was a Bebop 2 although the process is the same for both. Per the Bebop 1 manual, hold the power button for 10 seconds, then the led blinks green and orange, then turns green. But no go for you, that sucks.

My Bebop 2 fan turns on for a moment just as the Bebop 2 powers up, turns off for a short bit, then powers on again and runs continuously from then on.

What happens if you connect it via USB and press the button 13 times in quick succession? It should turn on USB networking where you can connect to it via telnet and maybe see what's wrong.
 
The fact that the fan is running at startup would suggest that the microcontroller (UC) ASIC will turn on the fan by default but then as the firmware running on the UC takes control it is switching it off during bootup (i.e. changing the state of some GPIO probably).

I get nothing so I think the UC is probably not even running - maybe a power circuit issue. Time to disassemble.
 

New Posts

Members online

Forum statistics

Threads
5,326
Messages
45,236
Members
8,068
Latest member
DesertDoc