Welcome to ParrotPilots!
Join our free parrot drone community today!
Sign up

blank screen - no video signal

MANISH

New member
Joined
Sep 2, 2018
Messages
4
Reaction score
0
I bought this ANAFI from dubai duty free and after a few flights , the video output is lost ,,, the drone flies but I cannot see the video ,,the screen is black .. I tried hard - reset and reinstalled the app but nothing is happening .. can anybody suggest how to fix it
 

patrick77

Member
Joined
Aug 25, 2018
Messages
9
Reaction score
3
I had exactly the same problem. Unfortunately afaik there is nothing you can do to fix it. You should send it back for repair/replacement.
 

MANISH

New member
Joined
Sep 2, 2018
Messages
4
Reaction score
0
I had exactly the same problem. Unfortunately afaik there is nothing you can do to fix it. You should send it back for repair/replacement.
dealing with dubai duty free is nightmare ... and parrot does not want to replace it ... ( only repair .. and that too the want the drone to be sent to UK ) I am stuck with no fault of mine
 

dmbrody

Well-known member
Joined
Jul 29, 2018
Messages
111
Reaction score
69
dealing with dubai duty free is nightmare ... and parrot does not want to replace it ... ( only repair .. and that too the want the drone to be sent to UK ) I am stuck with no fault of mine
Note to self: do not buy a drone from a duty free shop.
 

IM35461

Well-known member
Joined
Aug 2, 2018
Messages
164
Reaction score
45
Location
East Sussex, UK
With my replacement drone today on its third mission when I clicked on fly it gave me GPS data and battery level, etc but a jet black picture.

Checked to see if the camera view was blocked but then after about 20 or more seconds the picture suddenly appeared. The flight went okay but this does sound like the same problem.
 

Chillis

Member
Joined
Sep 8, 2018
Messages
6
Reaction score
3
My Anafi drone is doing the same thing. Video feed unavailable. Going to try the controller when I get home.

It functions properly otherwise.
 

kaypee

New member
Joined
Sep 9, 2018
Messages
3
Reaction score
0
Me too. Fine when connected to controller but when to connected via wi fi on Samsung s8 I get no video. I did a couple of times after several attempts but nothing since.
 

Chillis

Member
Joined
Sep 8, 2018
Messages
6
Reaction score
3
Try to reboot smarthphone.
That hasn't worked for me. With controller connected the connection comes and goes.

With WiFi I get nothing.

Switched to WiFi 5hz and that worked briefly last night. Today, no dice.

Since other have the same issue on different phones that says it is software.
 

dmbrody

Well-known member
Joined
Jul 29, 2018
Messages
111
Reaction score
69
That hasn't worked for me. With controller connected the connection comes and goes.

With WiFi I get nothing.

Switched to WiFi 5hz and that worked briefly last night. Today, no dice.

Since other have the same issue on different phones that says it is software.
User error.

You shouldn’t be using a phone without controller.

Just kidding.... or am I. :)
 
  • Like
Reactions: Chillis

Chillis

Member
Joined
Sep 8, 2018
Messages
6
Reaction score
3
User error.

You shouldn’t be using a phone without controller.

Just kidding.... or am I. :)
I wish that were the case. It cuts out with the controller connected as well.

Worked fine without controller prior to update.
 

kaypee

New member
Joined
Sep 9, 2018
Messages
3
Reaction score
0
Reboot doesn't help.

You should be able to use it without the controller as they use it as a selling point. Using 'follow me' to record your activity leaves your hands free whilst the phone just sits in your pocket.
 

Skassa

Well-known member
Joined
Aug 30, 2018
Messages
96
Reaction score
18
Location
Salerno Italy
Me too. Fine when connected to controller but when to connected via wi fi on Samsung s8 I get no video. I did a couple of times after several attempts but nothing since.
Try hard reset anafi. Powerup the anafi wait gimbal calibrating then push and hold power button until all green led come all red then drop power button. On android smarthphone try to uninstall (freeflight6) and install again.
 

IM35461

Well-known member
Joined
Aug 2, 2018
Messages
164
Reaction score
45
Location
East Sussex, UK
I had the same lag getting video on my second flight today. I was just getting my camera out to take a photo of the screen and the image appeared.

Next time I will try and have an action camera filming before I power up the drone.
 

Pixelstate

Member
Joined
Sep 11, 2018
Messages
9
Reaction score
4
Interesting thread. I have also experienced issues with video feed failing. This sometime results in a screen that is totally black and sometimes a screen that resembles dark digital noise (as the screen appears when not connected to the drone at all) While I have video failing other connection to the Drone appears to work as normal including I think video and image recording.

It is annoying (and unnerving) to experience and tarnishes an otherwise good experience. I have found that having the iphone in airplane mode appears to reduce the occurrence.
 

Chillis

Member
Joined
Sep 8, 2018
Messages
6
Reaction score
3
Haven't been able to fully test but I uninstalled the app from my phone and reinstalled. Video feed came back like normal.
 
  • Like
Reactions: Pixelstate

Skassa

Well-known member
Joined
Aug 30, 2018
Messages
96
Reaction score
18
Location
Salerno Italy
Haven't been able to fully test but I uninstalled the app from my phone and reinstalled. Video feed came back like normal.
Good i think some prefs saved in the old freeflight app. Better uninstall and install with new major update like last version.
 

Chillis

Member
Joined
Sep 8, 2018
Messages
6
Reaction score
3
Same problem occurred. Got several minutes of follow me flight in and then it just stopped. Checked my phone and screen was the black fuzz again.
 
  • Like
Reactions: Pixelstate

Latest threads

Forum statistics

Threads
1,686
Messages
14,440
Members
2,128
Latest member
Badger481