Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

FlightPlan does not work anymore...

S.C.C.

Well-known member
Joined
Jan 31, 2020
Messages
143
Reaction score
32
Location
CH
My Anafi won't start flight plans anymore. Everything looks fine on the FreeFlight6 screen, no error message (nor in the .json file from the drone). Manual flight with FreeFlight6 is still fine, both with the controller and with the smartphone alone. Same with FlightPlan, I can select and modify plans, only issue is that pressing the green arrow button to start the Flight Plan mission hasn’t any effect, the Anafi just hovers without any reaction.

This happened after installing Pix4Dcapture, but it may be a coincidence... I had to remove Pix4D anyway as it won't start without a data/GSM connection and I haven't any.

After removing Pix4D, I tried to uninstall and reinstall FreeFlight6, I also tried with a 2nd smartphone. I also did a reset of the drone by pressing the battery button. The problem is still the same ! I deleted the folders manually, reinstalled everything... same issue. It's like the drone itself refuses autonomous flights, as if it had been blocked.

I almost only use the drone for mapping now, and mapping with manual flight takes twice the time and is much less precise. Also the computing time to produce the maps is extravagant compared to planned flights...

I keep updating the app and firmwares, so they should be up to date (I tried an older phone with an older version, same issue).

Any idea ?

Edit : I have yet to try to remove tilt setting from the plan as described here FreeFlight6 V6.7.4 on App Store but this was never an issue. Also I contacted Parrot, but of course my Anafi is more than 2 years old now, so without warranty I couldn't even get anything else than an automatic reply !
 
Last edited:

BRC

Well-known member
Joined
Sep 2, 2019
Messages
438
Reaction score
177
Location
USA West Coast
My Anafi won't start flight plans anymore. Everything looks fine on the FreeFlight6 screen, no error message (nor in the .json file from the drone). Manual flight with FreeFlight6 is still fine, both with the controller and with the smartphone alone. Same with FlightPlan, I can select and modify plans, only issue is that pressing the green arrow button to start the Flight Plan mission hasn’t any effect, the Anafi just hovers without any reaction.

This happened after installing Pix4Dcapture, but it may be a coincidence... I had to remove Pix4D anyway as it won't start without a data/GSM connection and I haven't any.

After removing Pix4D, I tried to uninstall and reinstall FreeFlight6, I also tried with a 2nd smartphone. I also did a reset of the drone by pressing the battery button. The problem is still the same ! I deleted the folders manually, reinstalled everything... same issue. It's like the drone itself refuses autonomous flights, as if it had been blocked.

I almost only use the drone for mapping now, and mapping with manual flight takes twice the time and is much less precise. Also the computing time to produce the maps is extravagant compared to planned flights...

I keep updating the app and firmwares, so they should be up to date (I tried an older phone with an older version, same issue).

Any idea ?

Edit : I have yet to try to remove tilt setting from the plan as described here FreeFlight6 V6.7.4 on App Store but this was never an issue. Also I contacted Parrot, but of course my Anafi is more than 2 years old now, so without warranty I couldn't even get anything else than an automatic reply !
Hello SCC
This could be your issue
If you have placed a tilt setting in same timeline slot as takeoff (1st position) then drone will just hover after takeoff
Remove tilt setting in takeoff slot - save and then reload plan it will work
It's ok to have tilt settings in all the other slots
btw - after you make the correction you may need to initiate plan twice - only after a failed takeoff
i.e, start plan (takeoff) and if it just hovers land drone and the start plan again
Same happens when creating plans in FF6 or on esparus, think it started with FW1.8.0
Good luck
 

S.C.C.

Well-known member
Joined
Jan 31, 2020
Messages
143
Reaction score
32
Location
CH
Hello SCC
This could be your issue
If you have placed a tilt setting in same timeline slot as takeoff (1st position) then drone will just hover after takeoff
Remove tilt setting in takeoff slot - save and then reload plan it will work
It's ok to have tilt settings in all the other slots
btw - after you make the correction you may need to initiate plan twice - only after a failed takeoff
i.e, start plan (takeoff) and if it just hovers land drone and the start plan again
Same happens when creating plans in FF6 or on esparus, think it started with FW1.8.0
Good luck
OK, of course I have a tilt value different than 0 in all my plans ! Weird bug, but it would be 'fine' if this correction solves the issue.
I'll check as soon as I can...

Edit: That solved the problem, Thanks !
 
Last edited:

Latest threads

Members online

No members online now.

Forum statistics

Threads
4,988
Messages
43,460
Members
7,213
Latest member
Yanoaydo